Back to overview
Downtime
tst Oops we are down
May 10 at 02:03pm CEST
Resolved
May 10 at 02:04pm CEST
Back up!
Affected services
Updated
May 10 at 02:04pm CEST
Almost back up
Affected services
Created
May 10 at 02:03pm CEST
somebody tripped over the plug, now the server is shut down.
Affected services